Today, I wondered how reduce number of libraries installed in my Gentoo.

DOSBox is a DOS-emulator that uses the SDL-library which makes DOSBox very easy to port to different platforms. DOSBox has already been ported to many different platforms

dosbox
DOSBox still require libSDL 1.2, which doesn’t make me happy, so I found forum with patch.

Unfortunatelly it doesn’t fit on actual SVN revision, so I did small refactor, added games-emulation/dosbox-9999-r1 in ::ixit overlay with sdl2 USE flag. UPDATE: Also added snapshot, so no need unmask anything.

USE="sdl2" emerge -av games-emulation/dosbox::ixit

Seems like some changes regarding SDL 2.0 was incorporated by DOSBox. Now will DOSBox work with new SDL 2.0 out-of-box.

Up-to-date: Patch Ebuild iXit overlay
Have fun.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*